Search our Site

Security Updates

USN-3717-2: PolicyKit vulnerabilities

Ubuntu Security • 2018-07-17 09:00:02
Read more ...

Studio Blog

Google and the New SSL Requirements

Tech Blog • 2018-06-01 10:24:12

As of July 2018, Google will be enforcing its new SSL requirements for the web. This means that any site without SSL security installed will be marked as "unsafe" by most users' browsers. We highly recommend that all clients purchase and install an SSL certificate on their site. In most instances, the BASIC SSL option listed below should be fine. WILDCARD SSL is intended for users who want to cover multiple subdomains (subdomain.yourdomain.com, etc.) without having to purchase multiple certificates.

Read more ...